Vanaf 1 juni 2020 stopt Adobe met de ondersteuning van alle Magento 1.x versies. Wij als hostingprovider zullen de software die benodigd is voor het hosten van Magento 1.x shops blijven ondersteunen tot zeker eind 2020.

Welke impact heeft de end of life status van Magento 1 op hosting?

De end of life status van Magento 1.x heeft op twee manieren impact op een hostingprovider:

  1. Omdat er door Adobe geen security fixes meer beschikbaar worden gesteld worden Magento 1.x shops een gemakkelijk doelwit voor kwaadwillenden. Wanneer zij eenmaal binnen zijn,  kunnen ze zichzelf ook toegang verschaffen tot de server. In het geval van een shared hostingomgeving betekent dit dat ook andere webshops op die server gevaar lopen. Dit gevaar loop je bij Hypernode niet, omdat onze hostingomgevingen virtueel geïsoleerd zijn. De architectuur van het Hypernode platform biedt ons de mogelijkheid om onveilige shops te hosten zonder dat dit impact heeft op de rest van onze klanten.
  2. Naar mate de tijd verstrijkt zal de compatibiliteit van Magento 1.x met andere software steeds minder worden. Denk bijvoorbeeld aan PHP. Voor de veiligheid en kwaliteit van het hostingplatform is het wel van belang om deze software regelmatig te updaten en afscheid te nemen van onveilige versies. Dit is voor ons wel een uitdaging, want wij houden er niet van om oude software op ons platform te blijven aanbieden.

Tot zeker eind 2020 business as usual

Tot eind 2020 verandert er niets in onze dienstverlening. Tot die tijd is het business as usual.

Dat betekent dat we PHP 5.6, PHP 7.0  en PHP 7.1 tot eind 2020 zullen blijven aanbieden zolang dat verantwoord is.

Dat betekent ook dat je ons met een Magento 1 shop altijd mag blijven bellen/mailen/chatten m.b.t. hostingvragen of advies. Houd dan wel in je achterhoofd dat je met outdated software werkt en er mogelijk steeds meer problemen optreden die ook op de werking van je hosting van invloed kunnen zijn.

Ook zullen we je zo goed mogelijk op de hoogte blijven houden van nieuwe initiatieven op het gebied van Magento 1.

En na 2020?

Op dit moment is het aantal klanten dat gebruik maakt van Magento 1 nog groter dan het risico dat wij er als hostingprovider mee nemen. Maar er gaat een omslagpunt komen. Wanneer dat is, is nog koffiedik kijken. Er zijn namelijk veel initiatieven die voornemens zijn om de support voor Magento 1 over te nemen, zoals MageOne of OpenMage. Hypernode is een partnerschap aangegaan met MageOne om jullie shops zo lang mogelijk veilig te houden. Lees meer over dit partnerschap met MageOne hier. [Engels]

Een belangrijk onderdeel hiervan is de compatibiliteit met server software als PHP. Het is dus niet gezegd dat het na 2020 per definitie niet meer mogelijk is om een Magento 1 shop op een Hypernode te hosten.

Wil je echter ook nà 2020 de garantie hebben dat je je Magento 1 shop op een Hypernode kunt hosten, update dan in elk geval naar PHP 7.2. Dat is de laatste PHP versie die nog compatibiliteit met Magento 1 biedt. Het kan goed zijn dat we na 2020 van je gaan vragen om ten minste op die PHP versie te gaan draaien, omdat we oudere PHP versies niet meer aandurven.

Kijk naar initiatieven uit de community of stap over naar Magento 2 of Shopware

Verdiep je in initiatieven die de support van Magento 1 over willen nemen, zoals MageOne en OpenMage. Zij leggen zich er op toe om de core van Magento 1 te blijven beveiligen en houden zich bezig met de uitdaging van compatibiliteit met andere software. Hoe dit uitpakt en hoe toekomstbestendig het is, is echter nog niet duidelijk. Hier gaan we dieper op in in ons blog Magento 1 End Of Life: waarom je nu écht actie moet ondernemen.

Het is absoluut onze intentie om jullie zolang mogelijk te blijven ondersteunen, maar er komt een moment dat dit niet meer verantwoord is. We adviseren je dit niet af te wachten en over te stappen naar een systeem dat nog volop ondersteund en verder ontwikkeld wordt door een professionele partij, zoals Magento 2 of Shopware.