PHP_upgrade_the_Byte_way

Enkele weken geleden hebben we aangekondigd PHP 5.4 uit te faseren van ons Hypernode platform. 3 mei 2016 updaten we alle sites op ons Hypernode platform die nog op PHP 5.4 staan naar PHP 5.5. We raden je aan om je shop te testen en zelf alvast over te stappen, zodat je zeker weet dat je shop na 3 mei bereikbaar blijft.

Waarom we PHP 5.4 uitfaseren

De support voor PHP 5.4 is enige tijd geleden stopgezet door het PHP team, wat betekent dat er geen veiligheidsupdates meer worden uitgebracht. Door 3 mei te migreren naar PHP 5.5, zorgen we ervoor dat ons platform veilig blijft. PHP 5.5 wordt nog wel ondersteund en werkt goed voor zowel Magento 1 als Magento 2 shops.

Wat betekent dit voor jouw shop?

Omdat de upgrade naar PHP 5.5 mogelijk effect heeft op de werking van je sites, adviseren we je om eerst zelf grondig te testen of jouw shop goed werkt met PHP 5.5. Zo weet je zeker dat je shop na 3 mei bereikbaar blijft voor je klanten. Als je hebt getest en alles werkt, stap je over naar PHP 5.5 via het Service Panel. Zo heb je de migratie zelf in de hand. Als je niet zelf overstapt, wordt je shop 3 mei gemigreerd naar PHP 5.5.

Test met Vagrant of jouw shop werkt in PHP 5.5

Met onze Hypernode docker kun je je shop testen in PHP 5.5 (of PHP 7). Docker is een lokale dev omgeving die je in enkele minuten opzet op je eigen computer. Zo kun je je shop testen, zonder dat je bezoekers er iets van merken. Test je shop voor 3 mei en weet zeker dat alles blijft werken!

Gebruik de Hypernode docker om je shop in PHP 5.5 te testen (EN)

Stap over naar PHP 5.5 in 5 klikken

Getest en werkt alles correct? Stap dan direct over via het Service Panel in een paar klikken. Zo heb je de migratie zelf in de hand. Let op! Als je overstapt naar PHP 5.5, kun je niet meer terug naar PHP 5.4. Stap dus pas over als je zeker weet dat alles goed werkt.

Stap via het Service Panel in 5 klikken over naar PHP 5.5

Hulp nodig?

Kun jij wel wat hulp gebruiken bij deze update? Geen probleem. Byte werkt samen met veel webdevelopment-bureaus en zij hebben hun hulp aangeboden aan webshopeigenaren die wel wat hulp kunnen gebruiken bij de overstap naar PHP 5.5.

Wil je graag hulp bij de upgrade? Neem dan contact op met een van onze Partners. Zij zitten voor je klaar!

Gelijk over naar PHP 7?

PHP 7 is de opvolger van PHP 5 en sinds kort beschikbaar op ons Hypernodeplatform. PHP 7 biedt een hoop voordelen ten opzichte van PHP 5.5, waaronder een verbeterde snelheid! We zetten ons platform echter niet direct over naar PHP 7, omdat Magento 1 niet standaard compatible is met PHP 7.

Wil jij ook een snellere shop dankzij PHP 7? Stap dan zelf over via het Service Panel. Maak je shop wel eerst PHP 7 ready met de Inchoo_PHP7 module en test in Vagrant, voordat je overstapt. Hoe je dit doet leggen we uit in onze Hypernode Kennisbank.

Lees meer over de voordelen van PHP 7 in onze blogpost PHP 7: de belangrijkste voordelen.  

Scan je eigen Magento shop op veiligheidslekken