PHP 7.1 beschikbaar voor Magento 2.2 op Hypernode

PHP 7.1 is vanaf nu beschikbaar op Hypernode. Hoewel PHP 7.0 natuurlijk al voor een flinke snelheidsverbetering zorgde, brengt deze nieuwste PHP-versie nog enkele snelheids-verbeteringen met zich mee. Heb je een Magento 2.2 shop, dan raden we je aan om te upgraden.

Hoewel deze update in vergelijking met de release van versie 7.0 minder groot is, is het natuurlijk altijd een goed idee om up-to-date te blijven. Op lange termijn levert bijhouden minder werk en problemen op dan van een (sterk) verouderde PHP-versie in 1 keer over te stappen naar de nieuwste versie. Voor een overzicht van alle veranderingen ten opzichte van oudere versies kun je op de site van PHP terecht.

PHP 7.1 en Magento 2.2

Voordat je upgrade naar PHP 7.1 is het goed om te bedenken dat alleen Magento 2.2.0 installaties en nieuwer goed werken met deze PHP-versie. Upgraden heeft dus vooral zin als je shop draait op deze versie van Magento. Oudere versies van Magento worden officieel niet ondersteund. Heb je een Magento 2.1 shop of ouder en wil je per se gebruik maken van PHP 7.1, zorg er dan voor dat je eerst grondig test voordat je de overstap naar PHP 7.1 maakt.

Waarom overstappen op PHP 7?

Zoals we in dit blog al aantoonden, leidt PHP 7 tot veel snellere websites. Staat je shop nu nog op een PHP 5.x versie, dan valt er veel winst te behalen door te upgraden. Magento 2 biedt standaard ondersteuning voor PHP 7.0. Heb je een Magento 1.9 shop dan kun je ook overstappen naar PHP 7. We raden je dan wel aan om eerst de PHP-extensie van Inchoo te installeren voordat je upgrade.

Het overstappen naar een andere PHP versie kan heel eenvoudig geregeld worden via het Service Panel.  Het is wel heel belangrijk om eerst uitgebreid de werking van je shop te testen voordat je de overstap naar een nieuwe PHP-versie uitvoert op een live-omgeving. Op onze Hypernode Kennisbank leggen we je haarfijn uit hoe je een upgrade het beste kunt aanpakken.

Uitfasering PHP 5.5

PHP 5.5 is inmiddels end-of-life wat betekent dat er geen security updates meer worden uitgebracht. Daarom faseren we op 4 juni 2018 PHP 5.5 uit op Hypernode. Staat je shop momenteel nog op PHP 5.5, stap dan over naar een nieuwere PHP-versie. Start graag zo snel mogelijk met de upgrade, zo houd je alles in eigen hand en kun je uitgebreid de compatibiliteit van je shop met een nieuwe PHP-versie testen.

 op

Hette is als sales- en marketingmedewerker altijd bezig met nieuwe kansen voor Byte en het schrijven van nieuwe content. Buiten het werk houdt hij van wielrennen, Ajax en op z'n tijd een festival of feestje!